Dashboard Slowness and Latency

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 13:08 PDT

Investigating

Paragon is currently experiencing widespread latency while trying to load Paragon dashboard components. We are investigating and will update this page accordingly as we investigate this issue.
Posted Oct 14, 2025 - 12:56 PDT
This incident affected: Dashboard (Workflow Editor, Integrations Manager).