Degraded Performance for EU Hosted Customers

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 12:34 PDT

Identified

Some customers hosted in AWS EU cloud may see degraded workflow performance. We have identified the root cause and are deploying a fix.
Posted Aug 12, 2025 - 11:49 PDT
This incident affected: Workflows.