Paragon Cloud Services impacted

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:26 PDT

Update

UPDATE (12:30pm PST): We are seeing some resolution of performance across all systems, but are not back to normal operational standards.
Posted Oct 20, 2025 - 12:34 PDT

Identified

Paragon is currently affected by the ongoing AWS outage. Critical functions including Workflows, ActionKit, Managed Sync, and Connect Portal are experiencing significantly degraded performance. We are continuing to monitor and implement mitigating factors. More information regarding this outage can be found here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 01:30 PDT
This incident affected: Dashboard (Workflow Editor, Integrations Manager, Task History) and Workflows, Connect API, Connect Portal, ActionKit, Task History API, Managed Sync.