Dashboard and API Performance Issues

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 14:05 PDT

Monitoring

We have identified the root cause of the issue. Our team is currently monitoring the results to ensure stability.
Posted Sep 11, 2025 - 09:16 PDT

Investigating

We experienced downtime on the dashboard along with some API timeouts. Our team is actively investigating the root cause and working on mitigation.
Posted Sep 11, 2025 - 09:08 PDT
This incident affected: Dashboard (Workflow Editor, Integrations Manager, Task History).