Elevated API request errors and service unavailability

Incident Report for Paragon

Resolved

We experienced a service disruption due to database performance issues that affected our SDK authentication system. The issue was resolved by 2:49am PST, and our team continued to monitor throughout the night to ensure stability. We've implemented additional safeguards to prevent similar incidents in the future.
Posted Dec 20, 2024 - 08:15 PST

Identified

We have identified a potential issue and are working on implementing a fix.
Posted Dec 20, 2024 - 01:46 PST

Investigating

We are currently investigating elevated request error rates to API requests for api.useparagon.com and zeus.useparagon.com. Dashboard views, Connect Portal requests, and other requests to the API may fail to load due to request failures.
Posted Dec 20, 2024 - 00:49 PST
This incident affected: Dashboard (Workflow Editor, Task History) and Workflows, Connect API, Connect Portal.