Paragon Cloud Services impacted

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:28 PST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 04:14 PST

Identified

Paragon is currently affected by the ongoing Cloudflare outage. Critical functions including Dashboard, Connect API, ActionKit, and Connect Portal are experiencing significantly degraded performance. More information regarding this outage can be found here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 04:09 PST
This incident affected: Dashboard (Workflow Editor, Integrations Manager, Task History) and Workflows, Connect API, Connect Portal, ActionKit, Task History API, Managed Sync.