Degraded performance for high-volume workflows
Incident Report for Paragon
Resolved
We have confirmed that queueing latencies for high-volume workflows have returned to normal levels. All new workflow executions are performing as expected.

Our Support team is reaching out to a small number of customers who may continue to see older perpetually-running executions in Task History.
Posted Nov 20, 2023 - 17:32 PST
Identified
We are continuing to investigate this issue that is affecting a small number of high volume workflows.
Recent tasks for these workflows are executing as expected; however, some older tasks are still identified as perpetually executing.
Posted Nov 20, 2023 - 17:31 PST
Investigating
We are currently investigating an issue where high-volume workflows are experiencing abnormally high queueing latencies.

Workflows affected will appear in Task History as an actively executing workflow where the trigger step appears as perpetually executing.

Impact is limited to high-volume workflows (using a Fan Out step over >100 items, having >100 concurrent active executions, and workflows triggered by integration-based triggers).
Posted Nov 20, 2023 - 14:28 PST
This incident affected: Workflows.