Connect Portal Degradation
Incident Report for Paragon
Resolved
This issue is confirmed to be resolved.
Posted Sep 19, 2024 - 11:45 PDT
Monitoring
We have resolved this issue, but are continuing to monitor for the next few hours.
Posted Sep 19, 2024 - 11:13 PDT
Investigating
We are currently investigating an issue where select customers are experiencing slow load times or timeouts in the Connect Portal.
Posted Sep 19, 2024 - 10:33 PDT
This incident affected: Connect Portal.