Degraded Performance

Incident Report for Paragon

Resolved

The issue has been identified and mitigated after scaling up a number of services.
Posted Jun 25, 2025 - 13:15 PDT

Investigating

We have identified that a handful of services are experiencing slower-than-expected response times. Our team is currently investigating this issue.
Posted Jun 25, 2025 - 13:11 PDT
This incident affected: Dashboard (Workflow Editor, Integrations Manager, Task History) and Workflows.