EU Cloud Instance: Degraded Performance for Workflows and Connect API

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 10:27 PDT

Identified

We have identified the root cause of this issue and are working to restore performance within the hour.
Posted Jul 29, 2026 - 08:38 PDT

Investigating

Some customers hosted in EU cloud may see degraded performance. We are currently investigating the cause and will provide updates.
Posted Jul 29, 2026 - 07:24 PDT
This incident affected: Workflows and Connect API.