Degraded Task History and Dashboard UX Slowness

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 15:58 PST

Update

Event logs functionality has returned to normal. We are still seeing some lingering issues with task history and UX slowness, and will continue to update as functionality fully returns.
Posted Nov 04, 2025 - 15:11 PST

Update

We are continuing to work on a fix for this issue.
Posted Nov 04, 2025 - 14:44 PST

Identified

Paragon is currently experiencing task history performance issues, including Event Logs, alongside dashboard slowness in the UX. We have identified the issue and are working towards an expedient resolution.
Posted Nov 04, 2025 - 13:30 PST
This incident affected: Dashboard (Workflow Editor, Task History).