Degraded Test Step Performance

Incident Report for Paragon

Postmortem

On February 12, 2025, we identified an issue in our Test Workflow feature where using certain Paragon variables in workflow steps caused downstream issues in testing the full workflow. Upon reports from multiple customers, we escalated the issue and deployed a hot-fix to resolve it. We have also introduced additional automated tests for this scenario to prevent similar issues in the future.

Posted Feb 25, 2025 - 13:33 PST

Resolved

This incident has been resolved.
Posted Feb 21, 2025 - 14:12 PST

Identified

We've identified a fix for the issue with the Dashboard's Test Step functionality not passing data as expected. We are currently deploying the fix and anticipate the issue will be resolved this morning.
Posted Feb 21, 2025 - 08:54 PST

Investigating

We’ve identified issues with the Dashboard’s Test Step functionality not passing data as expected. We are actively working on a resolution.
Posted Feb 20, 2025 - 16:33 PST
This incident affected: Dashboard (Workflow Editor).