Degraded execution performance
Incident Report for Paragon
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 12:08 PDT
Investigating
We are currently investigating this issue.
Posted Jul 21, 2023 - 10:31 PDT
This incident affected: Dashboard (Task History) and Workflows.