Degraded Performance

Incident Report for Paragon

Resolved

This incident has been resolved as of 9:57am PST.
Posted Jul 31, 2025 - 09:57 PDT

Identified

Paragon services are currently experiencing degraded performance, including dashboard latency issues and long workflow queue times. API requests for api.useparagon.com and zeus.useparagon.com. Dashboard views, Connect Portal requests, and other requests to the API may fail to load due to request failures. We have identified multiple causes on this issue and are working to resolve ASAP.
Posted Jul 31, 2025 - 09:50 PDT
This incident affected: Dashboard (Workflow Editor, Integrations Manager, Task History) and Workflows, Connect API, Connect Portal, ActionKit, Task History API, Managed Sync.