US Cloud: Intermittent Connection Issues with Task History, Connect Portal, and Request Triggers

Incident Report for Paragon

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 17:15 PDT

Monitoring

The incident has been resolved. Our team is currently monitoring our services and will work on some additional improvements overnight.
Posted Jul 22, 2026 - 17:10 PDT

Update

We have identified some additional impacted services, with intermittent errors impacting a handful of request-based triggers. We are continuing to work towards a resolution.
Posted Jul 22, 2026 - 16:47 PDT

Identified

We have identified the issue and have been working to resolve the impacted services.
Posted Jul 22, 2026 - 16:17 PDT

Investigating

We are currently investigating an issue impacting our Connect Portal, Task History, and Task History API.
Posted Jul 22, 2026 - 15:23 PDT
This incident affected: Dashboard (Task History) and Workflows, Connect Portal, Task History API.